Terra - Strava API access changes for some integrations – Incident details

All systems operational

Strava API access changes for some integrations

Resolved
Operational
Started about 1 month agoLasted 15 days

Affected

Data Providers

Operational from 12:00 AM to 12:54 AM

Strava

Operational from 12:00 AM to 12:54 AM

Updates
  • Resolved
    UTC
    Resolved
    Strava's new API access requirements have been in effect since July 2 and affected integrations have had time to complete the required updates. Closing this notice — if your Strava connection still shows issues, please reach out to support.
  • Monitoring
    UTC
    Monitoring
    Since July 2, Strava has begun requiring developers to maintain an active Strava subscription (Standard Tier, effective June 30). Applications without one receive an “Inactive” response from Strava and stop delivering new data. Existing data is unaffected. If your Strava data has stopped, ensure the Strava account that owns your application has an active subscription, then reactivate the app in Strava’s API settings. Strava’s full migration deadline is September 1.