Terra - Elevated errors on API requests – Incident details

All systems operational

Elevated errors on API requests

Resolved
Partial outage
Started 6 days agoLasted about 3 hours

Affected

Terra Infrastructure

Partial outage from 1:08 AM to 3:46 AM

REST endpoints

Partial outage from 1:08 AM to 3:46 AM

Updates
  • Resolved
    UTC
    Resolved
    This incident is resolved. Between 01:08 and 03:46 UTC, requests authenticated with a Terra API key could fail with an authorization error. Your API keys were never changed or revoked - requests are succeeding again with no action needed. Provider connections and data delivery were unaffected and no data was lost.
  • Identified
    UTC
    Identified
    We have identified the cause and are applying a fix now. API keys have not been changed or revoked. Data from connected providers has continued to arrive throughout.
  • Investigating
    UTC
    Investigating
    We are investigating elevated errors on the Terra API. Requests authenticated with a Terra API key may fail with an authorization error. Provider connections and incoming data are not affected.