Terra - Degraded performance — Fitbit – Incident details

All systems operational

Degraded performance — Fitbit

Resolved
Degraded performance
Started 29 days agoLasted about 5 hours

Affected

Data Providers

Degraded performance from 11:45 AM to 1:50 PM, Operational from 1:50 PM to 2:27 PM, Degraded performance from 2:27 PM to 2:35 PM, Operational from 2:35 PM to 5:00 PM

Fitbit

Degraded performance from 11:45 AM to 1:50 PM, Operational from 1:50 PM to 2:27 PM, Degraded performance from 2:27 PM to 2:35 PM, Operational from 2:35 PM to 5:00 PM

Updates
  • Resolved
    UTC
    Resolved
    Resolved. Fitbit's platform recovered and we processed the full backlog of notifications that accumulated during their outage. All delayed Fitbit data has been synced — nothing was lost. Catch-up completed by 17:00 UTC.
  • Monitoring
    UTC
    Monitoring
    Fitbit's API is responding normally again in our checks. We are now working through the large backlog of notifications that accumulated during the outage, so Fitbit data will catch up progressively over the next hours — newest data first for most users. No data was lost. Google's own status page still lists their incident as open; we'll resolve here once delivery is fully back to normal.
  • Identified
    UTC
    Identified
    Google, who operate the Fitbit platform, have confirmed an outage on their side affecting sync for all Fitbit users (their status page: https://status.healthapp.google.com/incidents/P9M1yCB8EG8EN5SyC6jA). Fitbit data delivery remains reduced until Google resolves the issue. Data during this window is delayed, not lost — it will sync automatically once their service recovers.
  • Investigating
    UTC
    Investigating

    Fitbit's API is returning elevated errors, which is reducing Fitbit data delivery for some users. Data during this window will be delayed — it will sync automatically once Fitbit recovers. We're monitoring and will post updates here.